Habitat - Indoor :: Bad tank smell

Turtle tank setups and other indoor configurations.

Post Posted: Sat Aug 06, 2016 8:19 pm   Bad tank smell

Hi. I am new to the forum. I have a 16 year old female red eared slider turtle. I recently bought a Fluval 406 pump for 40 gallon tank. For the first few days all was well (no smell) but now unfortunately after 1 week the turtle smell is getting real bad. Any suggestions are appreciated. Thank you.
Bulliie
 
Posts: 2
Joined: Aug 6, 2016

Post Posted: Sun Aug 07, 2016 10:05 pm   Re: Bad tank smell

What kind of media do you have in the filter? Is the water cloudy too? Do you dechlorinate the water?
User avatar
steve
Site Admin
 
Posts: 29009
Joined: Apr 11, 2005
Location: New York, NY
Gender: Male

Post Posted: Wed Aug 10, 2016 10:34 am   Re: Bad tank smell

Thank you for replying. I am using everything that came with the Fluval 406. The water is cloudy and I use water from my sink. Please let me know how I should dechlorinate the water.
Bulliie
 
Posts: 2
Joined: Aug 6, 2016

Post Posted: Wed Aug 10, 2016 2:06 pm   Re: Bad tank smell

If you add carbon into the filter (I don't know if it comes with it), that will dechlorinate the water. It's probably cycling, but you can do a partial change to help with the smell/cloudiness.
User avatar
steve
Site Admin
 
Posts: 29009
Joined: Apr 11, 2005
Location: New York, NY
Gender: Male

Post Posted: Sat Aug 13, 2016 11:33 pm   Re: Bad tank smell

Be sure to watch as she eats, and confirm whether anything is left over. If there is, be sure to remove it as it will putrefy and contribute to the smell.
Jeremiah
 
Posts: 575
Joined: Jun 7, 2013
Gender: Male


Return to Habitat - Indoor

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests